Monthly Archives: October 2009

Phil 10.14.2009

7:30 – 4:00

  • Meeting with John, Mike, and Brian about column names
  • Working on Column view. Made good progress, but realized that all teh work really should be done on the server side. Going to port tomorrow

Phil 10.13.2009

7:30 – 4:00

  • Had to reset everyone’s roles today. Not sure why
  • Trying to set up a meeting to discuss data and column headers
  • Working on getting checkmarks and multiple selection to work using xml – done
  • Thinking about adding <options> tag, which would be a bunch of “where clauses” that could be added to the base query.
    • Make a new tab, for the time being we’ll call it “columns”. It’s king of like questions
    • In the “Edit” section, there is a “start” button that runs a “select *” query. THis is then used to build an XML document that has all the columns (minus timestamp and uid) in it as <select> elements. THe contents of each column is read into a Dictionary and used to create a set of <where> elements under the <select>.
    • The XML is used to create a tree like Questions. THere is a TextArea that allows editing of the XML
    • Clicking on the <where> tags causes the query to add to the SELECTstatement. WHere cluses are “OR-ed” together
  • Waiting for Anne to get back for meeting
  • Had Dong get more aquainted with Maven so that we can automate our dev process a little better.
  • Mesed up my Subversion access somehow. Spent some time chasing that down

Mike 10.10.09

Continuing to work on world map prototype based this demo: http://www.degrafa.org/source/DegrafaMapSample/DegrafaMapDemo.html.  I have a widget reading in SVG based xml and creating a degrafa based map but there are some kinks like weird transforms going on in the SVG that are hard to reproduce so some countries are showing up skewed or misplaced.

I really wish we weren’t so limited and could use some kind of map server to quickly produce maps like this: http://resources.esri.com/help/9.3/arcgisserver/apis/flex/samples/index.html.

Phil 10.9.2009

7:30 -7:30

  • Deployed the latest and greates at the Fort
  • Added an edgeDemo user that has access to fake data so Jeff can demo
  • Meeting ith ??? at 10:30
  • Need to make the Questinos interface a bit more like VIS1 – then I think we may be done?
  • Spent the rest of the afternoon working on Aarons build issues.

Phil 10.8.2009

7:30 – 3:00

  • Deployed the new version, there are a few bugs with the new tree views
    • “Set Query Builder” is not causing the appropriate table to be checked – may have been related to branch problems, below. Regardless, it seems to be working here
    • Clicking on the table (blue bar, not check box) selects the table but does not check the box – fixed
    • foo_bar_baz and foobar_baz will cause two branches, one for “foo” and one for “foobar”.  The “foobar” branch is correct, while the “foo” branch will have “foobar”entries in it. – fixed
  • Need to move the parser to a static method in “utils” – done

Buglist 10.7.2009

  • Need to be able to delete uploaded file
  • Need to set the role uid in setup xml to specify who can log into Administration tools
  • Ingest data is still different from dropdown date
  • “temp” file still exists on server. Needs to be deleted or changed to something less likely to entered by a user
  • Need to change the table dropdown to a tree with exclusionary checking – i.e. radio buttons

Phil 10.7.2009

7:30 – 4:00

  • Updated data and found a few bugs. See yesterday’s post for details
  • Working on changing table combobox to a tree – done.
  • Doing the same to the questions page – done
  • Rolled in Dong’s changes and burned a disk
  • Wrote up my 20% plan for Brian

Phil 10.6.2009

7:30 – 4:00

  • Getting ready for the next deploy
  • Deployed – there are still a few problems:
  • We need to be able to delete uploaded files
  • The date in the table Combobox is still the date of first ingest, not the last
  • “temp” file is left in the upload directory on the server
  • The table Combobox is getting way too many entries. Need to change it to a tree like the column view

Dong Shin Visibility Status – Oct, '09

Week o f 10/18

  • mvn plug in
    • fixed file path error – it work different on Windows 7 and 64 bit Vista?
    • added Flex Project pom file generation
    • cannot get the plugin to install on Flex Builder – Phil is looking into it

Week of 10/11

Week of 10/04

  • Role Management
    • added findNodeByID to RoleTree.ava
  • Working off the 10/2 bugs list
    • Upload control no longer launches html, fixed
    • UserID on AutoIngest needs to be a name, not a number
    • Auto-ingested files appear to be private (They can’t be seen by others)
    • Unable to set PUBLISH or PRIVATE in AutoIngest, fixed
    • “Duration” should be set to “Frequency”, or How Often” – fixed
    • Time popup for Duration disappears after each ingestion
    • “temp” appears after remote ingest. Remote file disappears (Figure 1)
    • File seem to be ingesting earlier than specified.
    • Update time does not appear in table select dropdown (Figure 2)
  • Fixed file types not filtering correctly in IngestManager
  • table selection control added to control by Role and User

Phil 10.5.2009

7:00 – 3:00

  • Ingested data, fixed some logins, and added a superuser that had somehow gotten deleted
  • Thinking about form builder – got a good start. It’s *big*
  • Dong found a bug with the QueryBuilderBase tree builder – fixed

Visiblity – to do

  • configurable html/flash based upload file control
  • return distinct table names for vis2
  • vis2 returning columns when tables are requested and the user doesn’t have any tables??????
  • Make sure parent Role can see the data set for children
  • User who has no tables causes vis2 to generate list of all columns in the database tables(?) when Get Tables button is clicked
  • Set others’ autoIngest data uneditable

Visibility Bug List 10/2/2009

  1. Upload control no longer launches html, fixed
  2. UserID on AutoIngest needs to be a name, not a number
  3. Auto-ingested files appear to be private (They can’t be seen by others)
  4. Unable to set PUBLISH or PRIVATE in AutoIngest, fixed
  5. “Duration” should be set to “Frequency”, or How Often” – fixed
  6. Time popup for Duration disappears after each ingestion
  7. Password disappears for first user?
  8. “temp” appears after remote ingest. Remote file disappears (Figure 1)
  9. Verify that “Add” and “Add as child” check to see that thereis a Question Name. May be also disable the ability to edit the Query text and only have that set by the widget (tooltip to explain)
  10. Mouseup in chart sometimes causes an “object.toString” tootip, which is weird
  11. File seem to be ingesting earlier than specified.
  12. Update time does not appear in table select dropdown (Figure 2)

Phil 10.2.2009

8:00 – 3:00

  • Autoingest appears to be working, though not at exactly the right time
  • Ingested data
  • Working on bug fixes
  • Fixed password issues
  • Added checkbox renderer to user role presentation
  • Added checks to “Add” and “Add Child” to Questions view in Advanced Query Builder

Phil 10.1.2009

7:30 – 4:30

  • Tried deploying but got nowhere. The code kept trying to connect to 127.0.0.1 rather than the actual server, even though I verified that the config files were correct
  • Deployed to laureldemo to see if there was any difference. It seemed to deploy just fine. There was one problem with private data being visible to other users. Dong’s fixing that now. Done
  • Burned  a new disk and going to try again
  • Talked to Anne, Pat can’t remember her password
  • Deployed the new version. Most things work, made a list of 12 bugs to bring in