- discussed with Phil about new database layout for FA/PA/RA….
- continue working on FA/RA(Req Assistant)
- converting Financial Assistant to Flex 4.6
- mix of 3.5 and 4.6 results in weird compile errors
- converted EdgeUtils to Flex 4.6
- converting Financial Assistant to Flex 4.6
Phil 9.10.13
8:00 – 4:30 SR
- Backups
- Downloaded WebStorm, and basically starting over. It’s been a while.
- Had a long discussion with Dong about how to hendle the next phase of development (i.e. FA/RA). We think there may be three phases:
Dong Shin 05.09.2013
- VizTool meeting at Fort
- lots of notes – at Phil’s blog
- continue working on FA
- working on Users (Service POCs) for Req’s – done!
- created table, _budget_centers_users to map Req’s and users
- CREATE TABLE IF NOT EXISTS `_budget_centers_service_pocs` (
`budget_center_id` int(11) NOT NULL,
`login` varchar(255) NOT NULL,
PRIMARY KEY (`budget_center_id`,`login`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1;
- CREATE TABLE IF NOT EXISTS `_budget_centers_service_pocs` (
- added AddServicePOCWindow
- created table, _budget_centers_users to map Req’s and users
- working on Users (Service POCs) for Req’s – done!
- created new project – ReqAssistant – copy from Project Assistant for FA
Phil 5.9.13
7:30 – 11:00 SR
- Deployed new FA and Javadoc for VSS
- Updated main web page to add links
- Added current users to FA db
- backed up everything but enh. Need to start doing that.
- Meeting with the PIT crew
- Add the ability to build custom, named queries instead of the dropdowns in the Funding Status screen
- Implies column config, or something like that
- sortable columns
- validator for matching parens, etc might be handy
- Anywhere a budget is entered by had, a dialog should come up when it it changed. (who, why, when, more?)
- Switch to Budget center based table structure. This may mean that the PIT crew will have to enter all the PA data over again with the new PA.
- Change sub projects so that there is simply a “parent id” field. Recursively search to build trees.
- Add individual tracability to req line items
- Funding Status
- Common elements are in top grid
- Unique items are in main grid
- Queries are stored in a dropdown
- SQL might have macros in it that cause a dialog to pop up with fields?
- Add the ability to build custom, named queries instead of the dropdowns in the Funding Status screen
Dong Shin 05.08.2013
- continue working on FA
- reworking Financial Status DataGrid to Budget Center/Contracts data
Phil 5.9.13
8:00 – 4:00 SR
- Both the integration and production servers are running smoothly.
- Regular backups.
- JUnit on ServerFacades. Almost done. Dong needs to add some comments to:
- saveSQLs (String queryName, String databaseName, String SQLs, String xml)
- saveMacros (String queryName, HashMap<String, String> valueMap)
- Installed JAutodoc. I want to try to improve the visibility to comments in ScriptFacades.
- Copied the VSS docs and a new FA to disk for tomorrow.
- Got Junit up and running on ScriptFacades. YUI next.
Dong Shin 05.07.2013
- deployed new FA, looks good
- continue working on FA
- cleaned up some unnecessary codes in Financial Assistant
- working on Funding Status Viewer
- updating Novetta Resume(?)
Phil 5.7.13
8:00 – 4:00 SR
- Pointed the server at the new cert on the production machine after verifying that the test machine was still happy.
- Rolled over to the new MySQL bd. A few hiccups getting the new db loaded, but after setting the max_packet_size in the conf file to 512M, everything worked when sourced from within mysql
- Deployed the new FA beta
- Deployed the new VSS. And it would have taken less time, except that winzip kept timing out when accessing a network folder. Copying everything to the local disk and compressing from there worked.
- Back to JUnit
- Review at 2:30, possibly 1:30.
- Updating all the various Novetta and successfactors resumes.
Dong Shin 05.06.2013
- continue working on FA
- got Project Viewer panel to display the financial data correctly – only the years the Req Data falls in
- fixed new project saving error
- tested freshly built VSS server and client
- null exception for _selectedSQLObject – fixed
Phil 5.6.13
8:00 – 4:00 SR
- My fresh-out-of-the -shop car stalled three times getting out of the neighborhood this morning. Gave up, got it home and took the other car in. Grrr.
- Backups
- Status report.
- Put the new server cert on the integration machine. Seems to be working.
- In playing around with VSS on the integration server, I think that the SQL editor may be misbehaving…. It’s also doing the same thing on the production machine. Not sure if it matters, but the problem definately shows if I type ‘show tables’ as the first query after the webapp comes up.
- Looks like the problem was a null pointer when no sql source was selected. Which means that the new db is ok. Looks like I can deploy the new certs and the new db tomorrow if the integration machines is still happy.
- Updated my Novetta profile. That is what I’d call a “lowest bidder” interface.
Dong Shin 05.03.2013
- deployed new FA – few problems..
creating new Project results in SQL errorfixed- INSERT INTO projects …. – Column count doesn’t match!
Sub Budget Center Name & Number not working correctlyfixedUn-Funded Amount = Req Amount – Funded (calculated, non-editable)– done- removed unfunded_amount from budget_centers table
Req Type should be non-addable in the comboboxdone- MIPR, REQ, EA, RTA, and EAO
- Upload Data should delete row 1 and last two lines from the excel spreadsheet
- built VSS and associated libs for more testing as we got weird errors on-site this morning
Phil 5.3.13
7:30 – 4:00 SR
- Backups
- Deployed new FA
- Customer meeting. Dong has the list of bugs. Actually, things went pretty well. I think we’re on track for alpha deployment next week.
- Test of DB upgrade on Integration?
- Error saving a script. Line 589 in ScriptFacades.
- Status Report for April
- More Junit.
Dong Shin 05.02.2013
- continue working on FA
- obligations/outlays data updates with fiscal_year from budget_centers
- getting View Financial Data to work with new database
- updated Project Editor to keep appropriation in budget_centers table
- updated Budget Information datagrid with new Req Data structure
- burned a CD for deployment tomorrow
Phil 5.2.13
8:00 – 4:00 SR
- Normal backups
- I tried making a full backup of the system using the following arguments:
- mysqldump – u root -pxxxx –all-databases –max_allowed_packet=512M –routines > fullbackup.sql
- That appeared to work fine, creating a file 148,338KB big
- I tried to ingest the file in the new instance on the integration machine using:
- mysql -u root -pxxxx < fullbackup.sql
- That gave the following error:
- ERROR 2006 (HY000) at line 4729: MySQL server has gone away
- Line 4729 turns out to be “INSERT INTO `query_logs` VALUES(…), which is *huge*. Not sure what to do about that. I did check to see that the line isn’t truncated, so that’s not the problem. Just to make sure, I ran it again with the same message at the same line
- This post at stackOverflow suggests that it’s a max_packet_size problem. Going to try that. Changed from 1M to 12M as per the suggestion.
- Same error, but new line (6367). Going to try 24M
- Same error, but new line (6373). Going to try 512M, same as the mysqldump command..?
- Yay! That did it.
- Finished generating C/C++ and Flex svn statisitics. Interestingly, in the “lines committed” charts, you can see the difference between mature development and ongoing development:
-

Mature profile of server codebase
-

Ongoing rapid development of GUI
- Ok, back to unit tests.
Dong Shin 05.01.2013
- continue working on FA
- Req Info datagrid preferences saved
- created a base class – FilterableDG that manages column preferences and saves info
- added column filter preferences to Project Mgmt panel
- ID column not in filter – used as tree navigation for Parent/Chile projects
- removed the references to budget_centers table when saving projects
- reworking Budget Info to get correct appropriation length – done
- noticed that sub center name and number were added to the budget_center table, not projects table – fixed
ALTER TABLE `projects` ADD `sub_center_name` VARCHAR( 255 ) NULL ,
ADD `sub_center_number` VARCHAR( 255 ) NULL
- Req Info datagrid preferences saved



You must be logged in to post a comment.